DT125X Servo doesnt move



  • Hi I just signed up to the old site but realized it was closing so i thought i would try here.

    I got my DTX in march this year, The YPVS has not worked since i have owned it. When i turn the Key And the bike is supposed to do the cleaning process the valve would not move at all, so i disconnected the cables and pulled the servo out and just had it plugged in. When i turned the key it barely moved at all, so i assumed there was a problem with the servo, i bought another off ebay and it does the exact same as the original so im a bit confused as to what could cause this.
    Thanks
    Lewis



  • Hello,

    I'll have a think amd get back to you mate. These servos are common to come by and it won't be anything too technical. Give me a few days and I'll come up with a few tests you can do.

    In the mean time feel free to get some photos of your bike up and welcome along.



  • By the sounds of things the CDI could be the fault. On the later dtx models the YPVS is run off the cdi. Before ruling that out though I would just put 12V's across the unit just to make sure it definitely works. I would also test continuity through the cables that go from the cdi to the servo.

    If the powervalve gets clogged up with dirty smoker juices, it can stop the YPVS from.rotating. Examine the condition of the powervalve and clean where necessary.

    I'll come.back with some.more ideas when I think of them.



  • Do you know which colour wires are the positive and negative on the servo so that i can test it off of the battery? I Used a multi meter on each pin from the CDI that goes to the servo and there's only one that gets any voltage at all and its only about 3 volts for less than a second. So i think it is The CDI that is faulty. 😞



  • Possibly. Possibly not. Either way those cdi's are not expensive.

    Won't matter on the servo mate. Positive will spin it one direction and negative will spin it another I imagine.



  • i just tested both my servos off the battery and both of them spin, Which means i bought a servo i didnt need ahah

    Thanks for the help by the way 🙂



  • Cool. So the servos are fine which means something else is wrong.



  • Any updates?

    Get your hands on another cdi and see if that's the issue. If you've tested all the wiring I can't think what else might cause it. I would have thought if it were the cdi then some othee things might not run.

    Maybe there is a relay somewhere but I'm not convinced



  • I haven't made any more progress yet but it seems the only way im going to get any closer to solving it will be to get another CDI, i did find a listing of someone selling a CDI With a fault of the YPVS not working but the bike still running, so it seems that they can go wrong on just servo controller.



  • I can't remember off yhe top of my head. But I almost feel like the older dtrs had a separate powervalve unit. Can't remember. As foe yours though. It wouldn't surprise me if its the cdi



  • Okay, I can finally say that the problem is solved!!! Bought a CDI off eBay for £30 recieved it today, fitted it and now the servo turns as its supposed to when the ignition is turned. It will be good to finally have some low down power.

    Now to move on tuning it for the New exhaust.



  • Good news matey 😃