Ignition Timing Problem - Won't Start



  • Calling all knowledgable chaps out there!!!

    I have a DTRE 125 which I bought as a project 6 years ago and have finally put it back together following a complete rebuild from the ground up but unfortunately I can't get it to start.

    Before I took it apart 6 years ago it had no spark and I had the stator coil re-wound twice. Upon blowing the stator for a third time it was discovered that
    a damaged flywheel was the culprit resulting in the stator/generator blowing. I then had it rewound a third time (and a new flywheel fitted) and although it had a spark it was only once I released my thumb from the starter button that it briefly sparked. I burnt out the starter motor trying to get it running.

    Fast forward 6 years I have completely rebuilt the engine and fitted a kickstart. I now have a spark when I kick it over and it does attempt to run and I get the odd backfire however whenever it shows any sign of bursting into life it kicks back through the kickstart and simply will not run, so I am guessing the timing is way off!!! The woodruff key is present so flywheel isn't simply spinning on the crank. I have a spare CDI and this hasn't cured the problem. Does anyone know how to properly time the dtre/x ?? Any help/advice would be appreciated.

    Thank you in advance.



  • Most likely it'll be the side stand switch. Immediately when you said spark when you released the starter button that this went through my mind.

    Either the side stand switch has failed, or the neutral switch. Both of which can be looped out of the circuit to remove them as the culprit.

    I doubt the timing is off as it's pretty hard to get wrong. The flywheel has the magneto built in and the pick up is fixed. Only the woodruff key alters the ignition, or aftermarket CDI.

    So I would look at the side stand switch being the problem.

    Failing that, a lose wire in the loom, check ignition barrel loom. or neutral switch.



  • @calum said in Ignition Timing Problem - Won't Start:

    Most likely it'll be the side stand switch. Immediately when you said spark when you released the starter button that this went through my mind.

    First things first, thank you for the advice 🙂

    I've unplugged both the side stand switch and the neutral switch but still the issue persists, every time I kick it over the lever flies straight back up leaving me with a rather sore foot!

    Interesting what you say about timing as I couldn't see how it could be adjusted besides a programmable cdi but assumed I must be missing something.

    I can't find anything loose in the loom, and I have a good earth on the ignition barrel. I suspect it could be something to do with the stator because as mentioned earlier it blew twice and after having the problem 'fixed' it did run (albeit for about 10 minutes before blowing again) and after having it re-wound for the third time it never ran again. I will probably order one from evilbay and hope I manage to get a functioning unit.



  • @2stroke4smoke ermmm unplugging those isn't going to help lol. They need to be in the circuit and 'closed' to give you a spark.

    If you want to run with them unplugged you'll need to link the wires on the loom plug together.



  • @finnerz89 Forgive my lack of knowledge about electrics, I have always considered them some form of witchcraft lol... So to eliminate them as a possible cause what would I need to do?



  • @2stroke4smoke Sorry yes, as @finnerz89 says, the system must be looped out.

    The fact that you're getting the same problem with it unplugged, means there has been no change in the system.

    Focus on one item at a time, my money is on the side stand switch. As said, it must be looped out so that the switch is closed.



  • @calum So I looped out both the side stand and neutral switches and somehow was able to just about start it after about 40 kicks, it barely ran though and wouldn't idle or climb past a certain rpm, it also backfired pretty loudly when kicking it over. I've posted a video of it running https://www.youtube.com/watch?v=qUmE7Z2nQy4 - you can see why I think it could be a timing issue now.

    The battery is dead and won't charge so for testing purposes I just bolted the positive and negative leads together to complete the circuit (maybe should have mentioned this earlier) I note however that the headlight did not come on.... could that be causing it to run so poorly?



  • @2stroke4smoke Yeah it won't run right if the power is weak. I think you are mistaken this bike for a four stroke. There is no timing. The static angle is fixed on the cdi. The magneto and pick ups are fixed. Provided you have these located on the bike appropriately you shoulkd be laughing.

    Sort the electrics out. You need approx 20'000 volts across the sparkplug to get it running right, it can't be botched.



  • Sounds like the carb to me if it's trying to run



  • @calum Solved!

    It was indeed timing related. The two wires leading to the pickup were the wrong way round. I swapped them over and re-soldered into place and voila it fired up first kick and runs as it should and revs freely.

    Thanks for the help 🙂



  • @2stroke4smoke Glad you solved it.

    Generally there is no reason to worry about timing on a stock two stroke. Naturally if it's been modified...